.

.

official statement from VSI regarding Meltdown and Spectre

OpenVMS on Itanium is not susceptible.
OpenVMS on Pre-EV6 Alpha is not susceptible, OpenVMS on EV6-and-later Alpha is OK so far.

Future OpenVMS on x86 is going to be OK too.

Official statement from VSI